VyOSでのIPSecサイト間VPN 接続手順書 - IDCフロンティア

セルフクラウド
VyOS での IPsec
サイト間 VPN 接続ガイド
サービスマニュアル
Ver.1.00
2014 年 7 月 23 日
株式会社 IDC フロンティア
目次
1. はじめに ........................................................................................................................... 1
1.1. 想定接続例 .......................................................................................................................1
1.2. IPsec 接続確認機器 ..........................................................................................................2
1.3. 必要な情報 と 構成図(例) ..........................................................................................3
1.4. 通信不可の場合のご注意点 ..............................................................................................4
1.5. セルフポータルでの作業手順 ..........................................................................................5
1.5.1.
VyOS マシンの作成 .............................................................................................5
1.5.2.
ネットワークの設定.............................................................................................8
1.6. スタティックルートの設定 ............................................................................................10
1.7. VyOS の基本コマンド .................................................................................................... 11
2. SSG550M の場合 .......................................................................................................... 12
2.1. クラウド側 VyOS の設定 .............................................................................................12
2.2. SSG550M の設定 ..........................................................................................................15
3. YAMAHA RTX1200 の場合 ............................................................................................ 17
3.1. クラウド側 VyOS の設定 .............................................................................................17
3.2. YAMAHA RTX1200 の設定............................................................................................21
4. Cisco7301 の場合 ......................................................................................................... 22
4.1. クラウド側 VyOS の設定 .............................................................................................22
4.2. Cisco7301 の設定..........................................................................................................25
5. Cisco RVS4000 の場合 ................................................................................................. 26
5.1. クラウド側 VyOS の設定 .............................................................................................26
5.2. Cisco RVS4000 の設定 .................................................................................................29
6. VyOS Core 6.4 の場合 .................................................................................................. 31
6.1. クラウド側 VyOS の設定 .............................................................................................31
6.2. ブランチ側 VyOS の設定 .............................................................................................34
7. お問合わせ ..................................................................................................................... 35
7.1. サポートコンテンツ .......................................................................................................35
7.2. オンラインサポート .......................................................................................................36
7.3. プレミアムサポート .......................................................................................................38
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
はじめに
1.
この文書では当社クラウド環境の VyOS での IPsec 接続の設定手順について記載します。
なお、お客様環境により接続条件等は変わってくるため、接続できることを保証するもの
ではありません。
VyOS は、外部のソフトウェアとなります為、当社サポート対象外となります。接続に関
するご不明な点は、以下をご参照ください。

VyOS マニュアルのダウンロード http://vyos.net/wiki/User_Guide

設定サポートをご希望の場合、弊社協力会社のご紹介が可能です。ご相談下さい。
また、当ガイドを見て、VyOS を利用したことにより、被った損害、及び損失について、
いかなる理由に関わらず、当社は一切責任を負わないものとします。予めご了承ください。
1.1.
想定接続例
ブランチ側
クラウド側
① お客様オフィス
セルフクラウド
② マネージドクラウド
セルフクラウド
③ セルフクラウド
セルフクラウド
アカウント間※
【注意】
セルフクラウドのアカウント間を接続する場合、同一ゾーン同士の IPsec 接続
はできません。別ゾーン間での IPsec 接続は可能です。
同一ゾーン内でプライベート通信を行いたい場合にはプライベートコネクトの
ご利用をご検討下さい。
-1© IDC Frontier Inc. All Rights Reserved.
セルフクラウド
1.2.
VyOS での IPsec サイト間 VPN 接続ガイド
IPsec 接続確認機器
以下は、当社にて、Vyatta CoreOS と IPsec 接続確認を行った機器となります。
VyOS は Vyatta CoreOS から派生した OS となる為、基本的には同様の動作環境となると考
えられます。
(※接続を保証するものではありません)
[機器名]
[OS]

Juniper SSG550M
( ScreenOS 6.1 )

YAMAHA RTX1200

Cisco7301
( IOS 12.4(25f) )

Cisco RVS4000
( Firmware Version 2.0.2.7 )

VyattaOS Core
( VC6.4-2012.05.31 )
( Firmware Version 10.01.38 )
-2© IDC Frontier Inc. All Rights Reserved
VyOS での IPsec サイト間 VPN 接続ガイド
セルフクラウド
1.3.
必要な情報 と 構成図(例)
この文書では、下記構成を例として説明します。値は実際の環境で置き換えて設定してく
ださい。この文書では、マネージドクラウド側に環境を「クラウド側」
、それに対向する接
続環境を「ブランチ側」と表現します。
ブ
ラ
ン
チ
側
デバイスのグローバル
IP アドレス
198.51.100.1
VyOS が IPsec で接続をする IP
デバイスの ID
branch
・任意の文字列。
・YAMAHA RTX1200 と Cisco7301 の場合
は不要
ネットワークアドレス
10.5.10.0/24
任意
ブ
ラ
ン
チ
側
NW
@branch
10.5.10.0/24
デバイス
198.51.100.1
お客様拠点など
Internet
トンネル
トンネル
203.0.113.1
セルフクラウド
NW
10.1.0.0/22
10.1.1.1/22
ク
ラ
ウ
ド
側
ク
ラ
ウ
ド
側
@cloud
VyOS に NAT される
グローバル IP アドレス
203.0.113.1
セルフポータルにて取得
VyOS の eth0 の IP アドレス
10.1.1.1
左記は例。セルフポータルで確
認
VyOS の ID
cloud
・任意の文字列
・YAMAHA RTX1200 の場合は不要
ネットワークアドレス
10.1.0.0/22
固定(サブネットは/22)
-3© IDC Frontier Inc. All Rights Reserved
セルフクラウド
項目内容
VyOS での IPsec サイト間 VPN 接続ガイド
本書での例
設定可能な選択肢
IPsec 事前共有鍵(Pre-shared Secret)
my_shared_secret
任意の文字列
IKE で用いる暗号化アルゴリズム
3DES
3DES/AES128/AES256
IKE で用いる認証用ハッシュアルゴリズム
MD5
MD5/SHA1
ESP で用いる暗号化アルゴリズム
3DES
3DES/AES128/AES256
ESP で用いる認証用ハッシュアルゴリズム
MD5
MD5/SHA1
1.4.
通信不可の場合のご注意点
「IPsec セッションは張れており、ping などの小さいパケットは疎通可能であるのに、
ファイルなどのパケットが通信できない」というような症状の場合は、以下の事象の可能
性がありますので、ご注意ください。
上記のような症状が発生する場合、ブランチ側ネットワークまでの途中経路の機器が
Path-MTU discovery に対応していない可能性があります。
インターネットの途中経路の機器が ICMP Type=3(Destination Unreachable)Code=4
(fragmentation needed and DF set)を返してこない場合に、Path-MTU discovery が行
えず、MTU サイズを超えるパケットが破棄されてしまいます。
対処方法としては、MTU サイズを変えていただく、または、上記 ICMP メッセージが
正しく届くように途中経路でのフィルタの見直し等をしていただく必要があります。
-4© IDC Frontier Inc. All Rights Reserved
セルフクラウド
1.5.
VyOS での IPsec サイト間 VPN 接続ガイド
セルフポータルでの作業手順
セルフポータルで必要な作業について以下にご案内します。
セルフポータルにログインします。 https://noahcloud.jp/portal
1.5.1.
VyOS マシンの作成
ご説明
操作方法
① VyOS 用のマシンを作成します。
ダッシュボードから「仮想マシンを作
成」ボタンをクリックします。
② 該当のゾーンを選択後、
VM タイプを選択します。VyOS
用のマシンには S2 以上を推奨い
たします。
※作成後にスペックの変更が可能
ですが、変更にはマシンの停止が
必要です。
テンプレートから、
「[LATEST]VyOS…」を選択。
※バージョンは変わる可能性が
あります。
-5© IDC Frontier Inc. All Rights Reserved
セルフクラウド
ご説明
③
VyOS での IPsec サイト間 VPN 接続ガイド
操作方法
-仮想マシン名とグループ名を任
意で設定します。(後で変更可能
です)
-ディスクを選択します。
必要な場合はCustom Disk で追
加ディスクを作成します。(後から
追加可能です)
-SSH Keyを設定します。
SSH Key名を任意で指定して、選
択項目からKeyを選択します。
基本的には以下のいずれかより選択となります。
[SSH鍵選択]・過去に作成した鍵と同じ鍵を利用する場合
[SSH鍵生成]・ 新たに鍵を作成する場合
※画面に表示されるKey情報は必ずファイルに保存して下さい。
この画面でしか表示されません。
[アップロード]・ 既存の鍵をアップロードする場合
マシン情報をご確認の上、契約約
※当社ではセキュリティ上、公開鍵認証を推奨しておりますが、
款に同意しますにチェックを入れ、
公開鍵認証を使用しない場合は[SSH鍵なし]を選択してくださ
「申し込み」をクリックすると、マシン
い。(その場合、デフォルトでは外部からのSSH接続が許可され
作成が開始します。
ておりませんので、コンソールからのログインが必要となります。)
④ マシンサイズにもよりますが、5分程
度で作成が完了します。
1台目の仮想マシンを作成する時は
30分前後かかる場合があります。
仮想マシンの作成が完了すると、画
面に初期パスワードが表示さ れま
す。
※作成途中で、下方のいずれかのボタンで他の画面に移
動可能ですが、初期パスワードはセルフポータル上で再
表示できませんので、ご注意ください。
-6© IDC Frontier Inc. All Rights Reserved
セルフクラウド
④
VyOS での IPsec サイト間 VPN 接続ガイド
仮想マシンの作成が完了すると、
画面にパスワードが表示されます
ので、ドラッグー右クリックーコピー
にて、お客様にて保存してくださ
い。
仮想マシンのログインIDは「vyos」
となります。
・初期パスワードは、登録したマスターのプライマリアドレスにメー
ルで送信されます。
・パスワードを忘れた場合は、パスワードリセットで再設定が可能
ですが、リセット時に仮想マシンの停止が必要です。
セキュリティ上、初期パスワードは変更することを推奨します。
⑤
[マイリソース]→[仮想マシ
ン]の画面で、作成した仮想マ
シンのステータスが「実行中」
になっていれば仮想マシン作成
の完了です。
-7© IDC Frontier Inc. All Rights Reserved
セルフクラウド
1.5.2.
ネットワークの設定
ご説明
①
VyOS での IPsec サイト間 VPN 接続ガイド
操作方法
[マイリソース]タブから[ネットワー
ク]を開きます。
VPN接続に使用する
グローバルIPアドレスを取得しま
す。(有償)
[IPアドレス取得]をクリック。
※ソースと書かれているIPアドレスはVyOS用には使用できませ
ん。VyOSではグローバルIPとプライベートIPが1対1に紐付ら
れている必要がありますが、ソースのIPは、仮想マシンと1対1
に紐付け(スタティックNAT)が設定できない為です。
②
VyOSを利用するゾーンを選択しま
す。
同意にチェックをして「確認」をしま
す。
③ 追加されたIPアドレスを選択します。
画面右の設定ボタンをクリックしま
す。
[スタティックNAT有効化]を選択し
ます。
※[ポートフォワーディング]や[ロードバランサー]で設定しな
いでください。
-8© IDC Frontier Inc. All Rights Reserved
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
④ 追加したIPアドレスを選択した状態
で、[ファイアウォール]タブを選択し
ます。
※全てのプロトコル、ポートが閉じられ
た状態から、設定した部分のみが開放
されます。
以下の設定を行います。
 ICMP
ICMPタイプ: 3
 TCP
ポート: 22番
[SSH用]
 UDP
ポート: 4500番
[VPN用]
 UDP
ポート: 500番
[VPN用]
ICMPコード: 4 [ping用]
※ソースCIDR :
許可する接続元CIDRを指定してください。
上記例では指定無し「0.0.0.0/0」としていますが、セキュリティ
上、必要なソースを指定することを推奨します。例えば、[VPN
用]であれば、ブランチ側のグローバルIPを指定します。
- IPアドレス単位の場合は /32 で設定します。
- 複数 CIDR の場合は「カンマ」区切りで設定可能です。
※ポート:
ファイアウォールで解放するポートの範囲を設定しま
す。
上記例では[SSH 用]にて 22 番を指定していますが、
セキュリティ上、お客様任意のポートにて指定するこ
とを推奨します。
⑤ 追加したIPアドレスを選択した状態
で、[ポートフォワード]タブを選択し
ます。
※ポート:
ファイアウォールで解放したポートの範囲を[パブリ
ックポート]に設定します。
上記例では SSH 用途にて、22 番を指定していますが、
セキュリティ上、
[パブリックポート]は、お客様任意
のポートにて指定することを推奨します。
-9© IDC Frontier Inc. All Rights Reserved
セルフクラウド
1.6.
VyOS での IPsec サイト間 VPN 接続ガイド
スタティックルートの設定
クラウド側の各仮想マシン内にて、VyOS 向けのスタティックルートを設定する必要が
あります。
Linux 系 OS の場合
1.下記のようにルーティングのファイルを作成する。
vi /etc/sysconfig/network-scripts/route-eth0
ベアメタルサーバーの場合、/route-bond1
10.5.10.0/24 via 10.1.1.1(例)
[宛先ネットワーク] via[ゲートウェイ IP]
2.反映の為、以下コマンドを実行
※SSH 接続や通信が切断されるのでコンソールから実施してください。
#
ifdown eth0
#
ifup eth0
← eth0 を停止
←
eth0 を起動
3.正しく設定されているか確認
#
ip route show
Windows 系 OS の場合
1.コマンドプロンプトを起動
netstat –r 現在のルーティング状況を確認
2.下記のようなコマンドを実行し、ルーティング設定(Administrator 権限で)
route -p add 10.5.10.0/24 mask 255.0.0.0 10.1.1.1 (例)
[宛先ネットワーク] [ネットマスク][ゲートウェイ IP]
※オプションの-p を入れることで OS 再起動後も設定が残ります。
3.正しく反映されているか確認
netstat –r 「固定ルート」の欄に正しく追加されていることを確認
- 10 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
1.7.
VyOS での IPsec サイト間 VPN 接続ガイド
VyOS の基本コマンド
VyOS の基本コマンドは以下となります。
 モードの移行
VyOS には 2 種類のモードがあり、モードを移行して編集を行います。
- 一般モード:[email protected]:~$
- 設定モード: [email protected]#
$ configure
# exit
(設定状態や動作状態の参照モード)
(設定ファイルの編集を行うモード)
一般モード から 設定モードへ移行
設定モードから 一般モードへ戻る
 設定の保存方法
# commit
設定の反映
# save
設定の保存。commit で反映させた後に使用
※commit だけでは、マシン再起動後に設定が消えてしまいます。
 設定内容の確認方法
接続が出来ない時などは、これらのコマンドにて設定内容を確認してください。
?
$ show ?
$ show c?
$ show c? を二回
ヘルプ。コマンド一覧(両モードで実行できます)
show の後に指定できるコマンド一覧(一般モード))
show c の後に続けて指定できるコマンド一覧
show c の後に続けて指定できるコマンドの説明
$ show configuration
設定内容の参照(一般モードで実行する場合)
# run show configuration
$ show ip route
$ show vpn ike sa
$ show vpn ipsec sa
$ show log vpn ipsec
設定内容の参照(設定モードで実行する場合)
ルーティングの確認
IKE SA の確認
ESP SA の確認
IPsec 関連のログ確認
 設定方法
設定手順(検証例)は、次項よりご案内します。
機器毎に章が分かれており、はじめにクラウド側 VyOS の設定手順を説明し、その後
それぞれの対向となるデバイスの設定手順を説明します。
- 11 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
SSG550M の場合
2.
以下に設定手順をご案内します。設定内容は例となります。適宜変更して設定してください。
クラウド側 VyOS の設定
2.1.
1.
IPsec の通信に用いるインターフェースの設定
set vpn ipsec ipsec-interfaces interface eth0
(これは当社初期設定で投入されていますので設定の必要はありません。
)
2.
IKE グループの設定
set vpn ipsec ike-group IKE-G proposal 1 encryption 3des
set vpn ipsec ike-group IKE-G proposal 1 hash md5
set vpn ipsec ike-group IKE-G lifetime 3600
設定例では、以下の内容を定義しています。
- ike-group(IKE グループ名)
:IKE-G 任意の名前を設定
- encryption(暗号化アルゴリズム)
:3DES
- hash(認証用ハッシュアルゴリズム)
:MD5
- lifetime(IKE の有効期限): 3600 秒(1 時間)※IKE の鍵交換間隔
* encryption と hash は複数種類登録が可能です。
「proposal1」とは異なる encryption と
hash を、
「proposal 2」
、
「proposal 3」として、同じグループ名で設定します。
3.
ESP グループの設定
set vpn ipsec esp-group ESP-G proposal 1 encryption 3des
set vpn ipsec esp-group ESP-G proposal 1 hash md5
set vpn ipsec esp-group ESP-G lifetime 1800
設定例では、以下の内容を定義しています。
- esp-group(ESP グループ名)
:ESP-G 任意の名前を設定
- encryption(暗号化アルゴリズム)
:3DES
- hash(認証用ハッシュアルゴリズム)
:MD5
- lifetime(ESP の有効期限): 1800 秒(30 分)※ESP の交渉間隔
* encryption と hash は複数種類登録が可能です。proposal1 とは異なる encryption と
hash を、
「proposal 2」
、
「proposal 3」として、同じグループ名で設定します。
- 12 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
4.
VyOS での IPsec サイト間 VPN 接続ガイド
NAT トラバーサルの設定の有効化
set vpn ipsec nat-traversal enable
(これは当社初期設定で投入されていますので設定の必要はありません。
)
5.
ブランチ側デバイスとの通信で用いる IKE グループと ESP グループを設定
set vpn ipsec site-to-site peer 198.51.100.1 ike-group IKE-G
set vpn ipsec site-to-site peer 198.51.100.1 default-esp-group ESP-G
*IP アドレスは実際の設定に置き換えてください。
- 198.51.100.1 は、ブランチ側デバイスのグローバル IP アドレスに置き換え。
(これ以降も同様に置き換えてください)
6.
接続で用いる認証方式を事前共有鍵方式に設定
set vpn ipsec site-to-site peer 198.51.100.1 authentication mode pre-shared-secret
set vpn ipsec site-to-site peer 198.51.100.1 authentication pre-shared-secret
my_shared_secret(*1 行で入力してください)
*「my_shared_secret」の部分は、実際の IPsec 事前共有鍵[Pre-shared Secret](任
意の文字列)で置き換えてください。
7.
自分自身(クラウド側 VyOS)の ID と対向デバイス(ブランチ側デバイス)の ID を
設定
set vpn ipsec site-to-site peer 198.51.100.1 authentication id @cloud
set vpn ipsec site-to-site peer 198.51.100.1 authentication remote-id @branch
クラウド側 VyOS とブランチ側デバイスの ID を付加します。
*ID の頭に@ (半角)を入力します。
* could と branch の部分は実際の値に置き換えてください。
- 13 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
8.
VyOS での IPsec サイト間 VPN 接続ガイド
自分自身(クラウド側 VyOS)の eth0 の IP アドレスを設定
set vpn ipsec site-to-site peer 198.51.100.1 local-address 10.1.1.1
*IP アドレスは実際の設定に置き換えてください。
- 198.51.100.1 は、ブランチ側デバイスのグローバル IP アドレスに置き換え。
- 10.1.1.1 は、クラウド側 VyOS の eth0 の IP アドレスに置き換え。
(これ以降も同様に置き換えてください)
9.
IPsec トンネルを通す宛先ネットワークと送信元ネットワークの対を設定
set vpn ipsec site-to-site peer 198.51.100.1 tunnel 1 local prefix 10.1.0.0/22
set vpn ipsec site-to-site peer 198.51.100.1 tunnel 1 remote prefix 10.5.10.0/24
*IP アドレスは実際の設定に置き換えてください。
- 10.1.0.0/22 は、クラウド側のネットワークに置き換え。
- 10.5.10.0/24 は、ブランチ側のネットワークに置き換え。
10. ファイアウォールのルール設定
set firewall name FW_RULE rule 100 action accept
set firewall name FW_RULE rule 100 source address 10.1.0.0/22
set firewall name FW_RULE rule 110 action accept
set firewall name FW_RULE rule 110 source address 10.5.10.0/24
*IP アドレスは実際の設定に置き換えてください。
*rule 番号(上記 100 と 110)は任意で設定します。
上記例では、
「FW_RULE」という名前(任意)のルールにて、クラウド側のネットワーク
アドレスとブランチ側のネットワークアドレスからのパケットを許可する設定を追加し
ています。
VyOS では、Firewall のルールで許可されていないパケットは拒否されます。
*もし eth0 に対して送受信時のフィルタを定義している場合(set interfaces ethernet
eth0 firewall in の設定がされている場合)は、クラウド側のネットワークとブラン
チ側のネットワークの双方で通信ができるためのルールが設定されている必要があり
ます。
*また、VyOS 自身に対してフィルタを定義している場合(set interfaces ethernet eth0
firewall local の設定がされている場合)は peer 同士の IP アドレスを許可する設定
が必要となります。
- 14 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
2.2.
VyOS での IPsec サイト間 VPN 接続ガイド
SSG550M の設定
ここでは以下の構成を例に説明します。設定内容は例となります。適宜変更して設定してく
ださい。
トンネルインターフェース
tunne1.1
WAN 側の Ethernet インターフェース
ethernet0/2
VPN 設定 ID
0x1
IKE 設定名
ike_cloud
VPN 設定名
vpn_cloud
すでに複数の IPsec サイト間接続 VPN の設定がされている場合は、すでにトンネル
インターフェース tunnel.1 と VPN 設定 ID 0x1 が使用されている可能性があります。
そのときは tunnel.2、 tunnel.3、や 0x2、 0x3 で適宜置き換えてください。
1.
トンネルインターフェースのゾーンを “Untrust” に設定
set interface "tunnel.1" zone "Untrust"
2.
トンネルインターフェースと WAN 側インターフェースの対応付け
set interface tunnel.1 ip unnumbered interface ethernet0/2
3.
IKE の設定
set ike gateway "ike_cloud" address 203.0.113.1 id "branch" Main local-id "cloud"
outgoing-interface
"ethernet0/2"
preshare
"my_shared_secret"
proposal
"pre-g2-3des-md5" (*1 行で入力してください)
設定例では、以下の内容を定義しています。
- ike_cloud →IKE 設定名
- 203.0.113.1 →クラウド側 VyOS に NAT されるグローバル IP アドレスに置き換え
- branch →ブランチ側デバイスの ID に置き換え
- cloud →クラウド側 VyOS の ID に置き換え
- ethernet0/2 →WAN 側の Ethernet インターフェース
- my shared secret →IPsec 事前共有鍵[Pre-shared Secret](任意の文字列)
- pre-g2-3des-md5 →IKE で用いる暗号化アルゴリズムとハッシュアルゴリズムに対応する値
- 15 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
4.
VyOS での IPsec サイト間 VPN 接続ガイド
NAT トラバーサルの設定
set ike gateway "ike_cloud" nat-traversal
set ike gateway "ike_cloud" nat-traversal udp-checksum
set ike gateway "ike_cloud" nat-traversal keepalive-frequency 5
NAT のステータスを保持するためキープアライブの設定も行います。
上記の例では 5 秒間隔で実施します。
5.
VPN の設定
set vpn "vpn_cloud" gateway "ike_cloud" no-replay tunnel idletime 0 proposal
"g2-esp-3des-md5"(*1 行で入力してください)
-「vpn_cloud」は VPN 設定名に置き換え。
-「g2-esp-3des-md5」は ESP で用いる暗号化アルゴリズムとハッシュアルゴリズムに対
応する値に、それぞれ置き換えてください。
6.
VPN の設定をトンネルインターフェースとバインド
set vpn "vpn_cloud" id 0x1 bind interface tunnel.1
set vpn "vpn_cloud" proxy-id local-ip 10.5.10.0/24 remote-ip 10.1.0.0/22 "ANY"
-「0x1」は実際の VPN 設定 ID に置き換え。
-「10.5.10.0/24」はブランチ側のネットワークアドレスに置き換え。
-「172.16.1.0/24」 はクラウド側のネットワークアドレスに置き換え。
7.
ルーティングの設定
set route 10.1.0.0/22 interface tunnel.1
宛先ネットワーク
*NW アドレスは実際の設定に置き換えてください。
クラウド側ネットワーク宛のパケットが、トンネルを通るようにするルーティング設定
- 16 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
YAMAHA RTX1200 の場合
3.
以下に設定手順をご案内します。設定内容は例となります。適宜変更して設定してくださ
い。
YAMAHA RTX1200 では、 NAT-Traversal 機能を利用し、 ID と IP アドレスが一致
しない構成で IPsec を利用したい場合、 IKE phase 1 で Aggressive mode しかサポート
していません。一方 VyOS は Main mode しかサポートしていません。
そのため IPIP トンネルを設定し、そのうえで IPsec トンネルを設定する必要がありま
す。
IPsec の前にトンネリングが行われるような構成の場合には、そのトンネリングに使われ
る通信をファイアウォールを許可する必要があります。
(※なお、セルフポータルの[ファイアウォール]では、IPIP 通信のフィルタ解除の
ルール設定が出来ません。しかし、VyOS から対向機器に対し VPN 通信を行ったタイミン
グで、動的に当社ファイアウォールでの IPIP 通信のフィルタが解除される為、対向側から
の VPN 通信も到達可能となりますので、問題ありません。
)
IPIP トンネルをつなぐ為の対向する IP アドレスを、以下を例として設定ご案内します。
- 192.168.123.1/24(クラウド側 VyOS)
- 192.168.123.2/24(ブランチ側 YAMAHA RTX1200)
※この 2 つの IP アドレスは、同じセグメントの任意のプライベート IP を設定します。
接続する VPN 環境内で、他で使われていない NW アドレスを設定してください。
クラウド側 VyOS の設定
3.1.
1.
IPIP トンネルの設定を行います。
set interfaces tunnel tun0 address 192.168.123.1/24
set interfaces tunnel tun0 encapsulation ipip
set interfaces tunnel tun0 local-ip 10.1.1.1
set interfaces tunnel tun0 mtu 1422
set interfaces tunnel tun0 remote-ip 198.51.100.1
*IP アドレスは実際の設定に置き換えてください。
- 10.1.1.1 は、クラウド側 VyOS の eth0 の IP アドレスに置き換え。
- 198.51.100.1 は、ブランチ側デバイスのグローバル IP アドレスに置き換え。
2.
IPsec の通信に用いるインターフェースの設定
set vpn ipsec ipsec-interfaces interface eth0
(これは当社初期設定で投入されていますので設定の必要はありません。
)
- 17 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
3.
VyOS での IPsec サイト間 VPN 接続ガイド
IKE グループの設定
set vpn ipsec ike-group IKE-G proposal 1 encryption 3des
set vpn ipsec ike-group IKE-G proposal 1 hash md5
set vpn ipsec ike-group IKE-G lifetime 3600
設定例では、以下の内容を定義しています。
- ike-group(IKE グループ名)
:IKE-G 任意の名前を設定
- encryption(暗号化アルゴリズム):3DES
- hash(認証用ハッシュアルゴリズム)
:MD5
- lifetime(IKE の有効期限)
: 3600 秒(1 時間)※IKE の鍵交換間隔
* encryption と hash は複数種類登録が可能です。proposal1 とは異なる encryption と
hash を、
「proposal 2」
、
「proposal 3」として、同じグループ名で設定します。
4.
ESP グループの設定
set vpn ipsec esp-group ESP-G proposal 1 encryption 3des
set vpn ipsec esp-group ESP-G proposal 1 hash md5
set vpn ipsec esp-group ESP-G lifetime 1800
設定例では、以下の内容を定義しています。
- esp-group(ESP グループ名)
:ESP-G 任意の名前を設定
- encryption(暗号化アルゴリズム):3DES
- hash(認証用ハッシュアルゴリズム)
:MD5
- lifetime(ESP の有効期限)
: 1800 秒(30 分)※ESP の交渉間隔
* encryption と hash は複数種類登録が可能です。proposal1 とは異なる encryption と
hash を、
「proposal 2」
、
「proposal 3」として、同じグループ名で設定します。
5.
ブランチ側デバイスとの通信で用いる IKE グループと ESP グループを設定
set vpn ipsec site-to-site peer 192.168.123.2 ike-group IKE-G
set vpn ipsec site-to-site peer 192.168.123.2 default-esp-group ESP-G
- 18 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
6.
VyOS での IPsec サイト間 VPN 接続ガイド
接続で用いる認証方式を事前共有鍵方式に設定
set vpn ipsec site-to-site peer 192.168.123.2 authentication mode pre-shared-secret
set vpn ipsec site-to-site peer 192.168.123.2 authentication pre-shared-secret
my_shared_secret(*1 行で入力してください)
*「my_shared_secret」の部分は実際の IPsec 事前共有鍵[Pre-shared Secret](任意
の文字列)で置き換えてください。
7.
自分自身(クラウド側 VyOS)の tun0 の IP アドレスを設定
set vpn ipsec site-to-site peer 192.168.123.2 local-address 192.168.123.1
*192.168.123.1 の部分は実際のクラウド側 VyOS の tun0 の IP アドレスの値に置
き換えてください。
8.
IPsec トンネルを通す宛先ネットワークと送信元ネットワークの対を設定
set vpn ipsec site-to-site peer 192.168.123.2 tunnel 1 local prefix 10.1.0.0/22
set vpn ipsec site-to-site peer 192.168.123.2 tunnel 1 remote prefix 10.5.10.0/24
*IP アドレスは実際の設定に置き換えてください。
- 10.1.0.0/22 は実際のクラウド側 NW アドレスに置き換え。
- 10.5.10.0/24 は実際のブランチ側のネットワークに置き換え。
- 19 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
9.
VyOS での IPsec サイト間 VPN 接続ガイド
ファイアウォールのルール設定
set firewall name FW_RULE rule 100 action accept
set firewall name FW_RULE rule 100 source address 10.1.0.0/22
set firewall name FW_RULE rule 110 action accept
set firewall name FW_RULE rule 110 source address 10.5.10.0/24
*IP アドレスは実際の設定に置き換えてください。
*rule 番号(上記 100 と 110)は任意で設定します。
上記例では、
「FW_RULE」という名前(任意)のルールにて、クラウド側のネットワーク
アドレスとブランチ側のネットワークアドレスからのパケットを許可する設定を追加し
ています。
VyOS では、Firewall のルールで許可されていないパケットは拒否されます。
*もし eth0 に対して送受信時のフィルタを定義している場合(set interfaces ethernet
eth0 firewall in の設定がされている場合)は、クラウド側のネットワークとブラン
チ側のネットワークの双方で通信ができるためのルールが設定されている必要があり
ます。
*また、VyOS 自身に対してフィルタを定義している場合(set interfaces ethernet eth0
firewall local の設定がされている場合)は peer 同士の IP アドレスを許可する設定
が必要となります。
- 20 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
YAMAHA RTX1200 の設定
3.2.
1.
IPIP トンネルの設定を行います。
tunnel select 1
tunnel encapsulation ipip
tunnel endpoint address 192.168.123.1 203.0.113.1
ip tunnel address 192.168.123.2/24
tunnel enable 1
*203.0.113.1 はクラウド側 VyOS のグローバル IP アドレスに置き換えてください。
2.
IPsec の設定
tunnel select 2
ipsec tunnel 2
ipsec sa policy 2 2 esp 3des-cbc md5-hmac
ipsec ike duration ipsec-sa 2 1800
ipsec ike encryption 2 3des-cbc
ipsec ike group 2 modp1024
ipsec ike hash 2 md5
ipsec ike keepalive use 2 on icmp-echo 10.1.1.1
ipsec ike local address 2 192.168.123.2
ipsec ike pre-shared-key 2 text my_shared_secret
ipsec ike remote address 2 192.168.123.1
tunnel enable 2
ipsec auto refresh on
*10.1.1.1 はクラウド側 VyOS の eth0 の IP アドレスに置き換えて下さい。
IPIP トンネル上で NAT-Traversal を利用しない IPsec トンネルを設定する場合、
IPIP トンネルのセッションがタイムアウトすることで通信ができなくなる可能性があり
ます。そのため ipsec ike keepalive コマンドでキープアライブの設定を行います。
3.
ルーティングの設定
ip route 10.1.0.0/22 gateway tunnel 2
宛先ネットワーク
*NW アドレスは実際の設定に置き換えてください。
クラウド側ネットワーク宛のパケットが、トンネルを通るようにするルーティング設定
- 21 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
Cisco7301 の場合
4.
以下に設定手順をご案内します。設定内容は例となります。適宜変更して設定してください。
4.1.
1.
クラウド側 VyOS の設定
IPsec の通信に用いるインターフェースの設定
set vpn ipsec ipsec-interfaces interface eth0
(これは当社初期設定で投入されていますので設定の必要はありません。
)
2.
IKE グループの設定
set vpn ipsec ike-group IKE-G proposal 1 encryption 3des
set vpn ipsec ike-group IKE-G proposal 1 hash md5
set vpn ipsec ike-group IKE-G lifetime 3600
設定例では、以下の内容を定義しています。
- ike-group(IKE グループ名)
:IKE-G 任意の名前を設定
- encryption(暗号化アルゴリズム):3DES
- hash(認証用ハッシュアルゴリズム)
:MD5
- lifetime(IKE の有効期限)
: 3600 秒(1 時間)※IKE の鍵交換間隔
* encryption と hash は複数種類登録が可能です。proposal1 とは異なる encryption と
hash を、
「proposal 2」
、
「proposal 3」として、同じグループ名で設定します。
3.
ESP グループの設定
set vpn ipsec esp-group ESP-G proposal 1 encryption 3des
set vpn ipsec esp-group ESP-G proposal 1 hash md5
set vpn ipsec esp-group ESP-G lifetime 1800
設定例では、以下の内容を定義しています
- esp-group(ESP グループ名)
:ESP-G 任意の名前を設定
- encryption(暗号化アルゴリズム):3DES
- hash(認証用ハッシュアルゴリズム)
:MD5
- lifetime(ESP の有効期限)
: 1800 秒(30 分)※ESP の交渉間隔
* encryption と hash は複数種類登録が可能です。proposal1 とは異なる encryption と
hash を、
「proposal 2」
、
「proposal 3」として、同じグループ名で設定します。
- 22 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
4.
VyOS での IPsec サイト間 VPN 接続ガイド
NAT トラバーサルの設定を有効化
set vpn ipsec nat-traversal enable
(これは当社初期設定で投入されていますので設定の必要はありません。
)
5.
ブランチ側デバイスとの通信で用いる IKE グループと ESP グループを設定
set vpn ipsec site-to-site peer 198.51.100.1 ike-group IKE-G
set vpn ipsec site-to-site peer 198.51.100.1 default-esp-group ESP-G
198.51.100.1 は実際のブランチ側デバイスのグローバル IP アドレスで置き換えてく
ださい。
(これ以降も同様に置き換えてください。
)
6.
接続で用いる認証方式を事前共有鍵方式に設定
set vpn ipsec site-to-site peer 198.51.100.1 authentication mode pre-shared-secret
set vpn ipsec site-to-site peer 198.51.100.1 authentication pre-shared-secret
my_shared_secret(*1 行で入力してください)
*「my_shared_secret」の部分は実際の IPsec 事前共有鍵[Pre-shared Secret](任意
の文字列)で置き換えてください。
7.
クラウド側 VyOS の ID を設定
set vpn ipsec site-to-site peer 198.51.100.1 authentication id @cloud
ID の設定には ID の頭に “@(アットマーク)” を付加します。could の部分は実際の
値に置き換えてください。
- 23 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
8.
VyOS での IPsec サイト間 VPN 接続ガイド
クラウド側 VyOS の eth0 の IP アドレスを設定
set vpn ipsec site-to-site peer 198.51.100.1 local-address 10.1.1.1
*10.1.1.1 の部分は実際のクラウド側 VyOS の eth0 の IP アドレスの値に置き換え
てください。
9.
IPsec トンネルを通す宛先ネットワークと送信元ネットワークの対を設定
set vpn ipsec site-to-site peer 198.51.100.1 tunnel 1 local prefix 10.1.0.0/22
set vpn ipsec site-to-site peer 198.51.100.1 tunnel 1 remote prefix 10.5.10.0/24
- 198.51.100.1 は実際のブランチ側デバイスのグローバル IP アドレスに置き換え。
- 10.1.0.0/22 は実際のクラウド側のネットワークアドレスに置き換え。
- 10.5.10.0/24 は実際のブランチ側のネットワークに置き換え。
10. ファイアウォールのルール設定
set firewall name FW_RULE rule 100 action accept
set firewall name FW_RULE rule 100 source address 10.1.0.0/22
set firewall name FW_RULE rule 110 action accept
set firewall name FW_RULE rule 110 source address 10.5.10.0/24
*IP アドレスは実際の設定に置き換えてください。
*rule 番号(上記 100 と 110)は任意で設定します。
上記例では、
「FW_RULE」という名前(任意)のルールにて、クラウド側のネットワークアド
レスとブランチ側のネットワークアドレスからのパケットを許可する設定を追加しています。
VyOS では、Firewall のルールで許可されていないパケットは拒否されます。
*もし eth0 に対して送受信時のフィルタを定義している場合(set interfaces ethernet
eth0 firewall in の設定がされている場合)は、クラウド側のネットワークとブランチ側
のネットワークの双方で通信ができるためのルールが設定されている必要があります。
*また、VyOS 自身に対してフィルタを定義している場合(set interfaces ethernet eth0
firewall local の設定がされている場合)は peer 同士の IP アドレスを許可する設定が必
要となります。
- 24 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
4.2.
1.
VyOS での IPsec サイト間 VPN 接続ガイド
Cisco7301 の設定
IKE の設定
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key my_shared_secret address 203.0.113.1
crypto isakmp nat keepalive 20
*203.0.113.1 はクラウド側 VyOS のグローバル IP に置き換えてください。
2.
IPsec のポリシーを設定
crypto ipsec transform-set myset esp-3des esp-md5-hmac
*上記例では、myset という名前(任意)でポリシーを定義しています。
3.
対向の ID を定義
crypto identity cloudid
fqdn cloud
*上記例では、cloudid という名前(任意)で cloud という ID を設定しています。
4.
IPsec ピアの設定
crypto map myvpn 10 ipsec-isakmp
set peer 203.0.113.1
set transform-set myset
set identity cloudid
match address 101
*上記例では、myvpn という名前(任意)で設定しています。
5.
IPsec トンネルを通す IP パケットの定義
access-list 101 permit ip 10.5.10.0 0.0.0.255 10.1.0.0 0.0.3.255
- 25 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
Cisco RVS4000 の場合
5.
以下に設定手順をご案内します。設定内容は例となります。適宜変更して設定してください。
5.1.
1.
クラウド側 VyOS の設定
IPsec の通信に用いるインターフェースの設定
set vpn ipsec ipsec-interfaces interface eth0
(これは当社初期設定で投入されていますので設定の必要はありません。
)
2.
IKE グループの設定
set vpn ipsec ike-group IKE-G proposal 1 encryption 3des
set vpn ipsec ike-group IKE-G proposal 1 hash md5
set vpn ipsec ike-group IKE-G lifetime 3600
設定例では、以下の内容を定義しています。
- ike-group(IKE グループ名)
:IKE-G 任意の名前を設定
- encryption(暗号化アルゴリズム):3DES
- hash(認証用ハッシュアルゴリズム)
:MD5
- lifetime(IKE の有効期限)
: 3600 秒(1 時間)※IKE の鍵交換間隔
* encryption と hash は複数種類登録が可能です。proposal1 とは異なる encryption と
hash を、
「proposal 2」
、
「proposal 3」として、同じグループ名で設定します。
3.
ESP グループの設定
set vpn ipsec esp-group ESP-G proposal 1 encryption 3des
set vpn ipsec esp-group ESP-G proposal 1 hash md5
set vpn ipsec esp-group ESP-G lifetime 1800
設定例では、以下の内容を定義しています。
- esp-group(ESP グループ名)
:ESP-G 任意の名前を設定
- encryption(暗号化アルゴリズム):3DES
- hash(認証用ハッシュアルゴリズム)
:MD5
- lifetime(ESP の有効期限)
: 1800 秒(30 分)※ESP の交渉間隔
* encryption と hash は複数種類登録が可能です。proposal1 とは異なる encryption と hash
を、
「proposal 2」
、
「proposal 3」として、同じグループ名で設定します。
- 26 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
4.
VyOS での IPsec サイト間 VPN 接続ガイド
NAT トラバーサルの設定の有効化
set vpn ipsec nat-traversal enable
(これは当社初期設定で投入されていますので設定の必要はありません。
)
5.
ブランチ側デバイスとの通信で用いる IKE グループと ESP グループを設定
set vpn ipsec site-to-site peer 198.51.100.1 ike-group IKE-G
set vpn ipsec site-to-site peer 198.51.100.1 default-esp-group ESP-G
* 198.51.100.1 は実際のブランチ側デバイスのグローバル IP アドレスで置き換えてく
ださい。
(これ以降も同様に置き換えてください。
)
6.
接続で用いる認証方式を事前共有鍵方式に設定
set vpn ipsec site-to-site peer 198.51.100.1 authentication mode pre-shared-secret
set vpn ipsec site-to-site peer 198.51.100.1 authentication pre-shared-secret
my_shared_secret (*1 行で入力してください)
*「my_shared_secret」の部分は実際の IPsec 事前共有鍵[Pre-shared Secret]
(任意
の文字列)で置き換えてください。
7.
ID 設定
set vpn ipsec site-to-site peer 198.51.100.1 authentication id @cloud
set vpn ipsec site-to-site peer 198.51.100.1 authentication remote-id @branch
クラウド側 VyOS とブランチ側デバイスの ID を設定します。
*ID の頭に@ (半角)を付加します。
* could と branch の部分は実際の値に置き換えてください。
- 27 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
8.
VyOS での IPsec サイト間 VPN 接続ガイド
自分自身(クラウド側 VyOS)の eth0 の IP アドレスを設定
set vpn ipsec site-to-site peer 198.51.100.1 local-address 10.1.1.1
上記の実行例のうち 10.1.1.1 の部分は実際のクラウド側 VyOS の eth0 の IP アド
レスの値に置き換えてください。
9.
IPsec トンネルを通す宛先ネットワークと送信元ネットワークの対を設定
set vpn ipsec site-to-site peer 198.51.100.1 tunnel 1 local prefix 10.1.0.0/22
set vpn ipsec site-to-site peer 198.51.100.1 tunnel 1 remote prefix 10.5.10.0/24
- 198.51.100.1 は実際のブランチ側デバイスのグローバル IP アドレスに置き換え。
- 10.1.0.0/22 は実際のクラウド側のネットワークアドレスに置き換え。
- 10.5.10.0/24 は実際のブランチ側のネットワークに置き換え。
10.
ファイアウォールのルール設定
set firewall name FW_RULE rule 100 action accept
set firewall name FW_RULE rule 100 source address 10.1.0.0/22
set firewall name FW_RULE rule 110 action accept
set firewall name FW_RULE rule 110 source address 10.5.10.0/24
*NW アドレスは実際の設定に置き換えてください。
*rule 番号(上記 100 と 110)は任意で設定します。
上記例では、
「FW_RULE」という名前(任意)のルールにて、クラウド側のネットワーク
アドレスとブランチ側のネットワークアドレスからのパケットを許可する設定を追加し
ています。
VyOS では、Firewall のルールで許可されていないパケットは拒否されます。
*もし eth0 に対して送受信時のフィルタを定義している場合(set interfaces ethernet
eth0 firewall in の設定がされている場合)は、クラウド側のネットワークとブランチ側
のネットワークの双方で通信ができるためのルールが設定されている必要があります。
*また、VyOS 自身に対してフィルタを定義している場合(set interfaces ethernet eth0
firewall local の設定がされている場合)は peer 同士の IP アドレスを許可する設定が必
要となります。
- 28 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
5.2.
VyOS での IPsec サイト間 VPN 接続ガイド
Cisco RVS4000 の設定
1.
ローカルセキュリティゲートウェイ
のタイプを“IP とドメイン名
(FQDN)による認証”に設定します。
2.
ドメイン名にブランチ側デバイスの
ID(この例では“branch”)を設定
します。
3.
ローカルセキュリティのグループを
“サブネット”に設定し、IP アドレ
スとサブネットマスクにブランチ側
のネットワーク情報を入力します。
1.
リモートセキュリティゲートウェイ
のタイプを“IP とドメイン名
(FQDN)による認証”に設定します。
2.
ドメイン名にクラウド側 VyOS の
ID(この例では“cloud”)を設定し
ます。
3.
IP アドレスにクラウド側 VyOS
のグローバル IP アドレスを入力し
ます。
4.
リモートセキュリティグループのタ
イプを“サブネット”にし、クラウ
ド側ネットワークの情報を入力しま
す。
- 29 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
1.
VyOS での IPsec サイト間 VPN 接続ガイド
キー入力モードを“事前共有キー付き
IKE”にし、暗号化、認証、グループ
をそれぞれ設定します。
2.
事前共有キーにクラウド側 VyOS で
設定した事前共有キーを入力します。
- 30 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
VyOS Core 6.4 の場合
6.
クラウド側 VyOS とブランチ側 VyOS(お客様用意/セルフ/マネージド)を接続する場
合は、以下の手順となります。設定内容は例となります。適宜変更して設定して下さい。
【注意】セルフクラウドのアカウント間を接続する場合、同一ゾーン同士の IPsec
接続はできません。別ゾーン間での IPsec 接続は可能です。同一ゾーン内でプライ
ベート通信を行いたい場合にはプライベートコネクトのご利用をご検討下さい。
6.1.
1.
クラウド側 VyOS の設定
IPsec の通信に用いるインターフェースの設定
set vpn ipsec ipsec-interfaces interface eth0
(これは当社初期設定で投入されていますので設定の必要はありません。
)
2.
IKE グループの設定
set vpn ipsec ike-group IKE-G proposal 1 encryption 3des
set vpn ipsec ike-group IKE-G proposal 1 hash md5
set vpn ipsec ike-group IKE-G lifetime 3600
設定例では、以下の内容を定義しています。
- ike-group(IKE グループ名)
:IKE-G 任意の名前を設定
- encryption(暗号化アルゴリズム):3DES
- hash(認証用ハッシュアルゴリズム)
:MD5
- lifetime(IKE の有効期限)
: 3600 秒(1 時間)※IKE の鍵交換間隔
* encryption と hash は複数種類登録が可能です。proposal1 とは異なる encryption と hash
を、
「proposal 2」
、
「proposal 3」として、同じグループ名で設定します。
3.
ESP グループの設定
set vpn ipsec esp-group ESP-G proposal 1 encryption 3des
set vpn ipsec esp-group ESP-G proposal 1 hash md5
set vpn ipsec esp-group ESP-G lifetime 1800
設定例では、以下の内容を定義しています。
- esp-group(ESP グループ名)
:ESP-G 任意の名前を設定
- encryption(暗号化アルゴリズム):3DES
- hash(認証用ハッシュアルゴリズム)
:MD5
- lifetime(ESP の有効期限)
: 1800 秒(30 分)※ESP の交渉間隔
* encryption と hash は複数種類登録が可能です。proposal1 とは異なる encryption と
hash を、
「proposal 2」
、
「proposal 3」として、同じグループ名で設定します。
- 31 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
4.
VyOS での IPsec サイト間 VPN 接続ガイド
NAT トラバーサルの設定の有効化
set vpn ipsec nat-traversal enable
(これは当社初期設定で投入されていますので設定の必要はありません。
)
5.
ブランチ側デバイスとの通信で用いる IKE グループと ESP グループを設定
set vpn ipsec site-to-site peer 198.51.100.1 ike-group IKE-G
set vpn ipsec site-to-site peer 198.51.100.1 default-esp-group ESP-G
*198.51.100.1 は実際のブランチ側デバイスのグローバル IP アドレスで置き換えてく
ださい。
(これ以降も同様に置き換えてください。
)
6.
接続で用いる認証方式を事前共有鍵方式に設定
set vpn ipsec site-to-site peer 198.51.100.1 authentication mode pre-shared-secret
set vpn ipsec site-to-site peer 198.51.100.1 authentication pre-shared-secret
my_shared_secret (*1 行で入力してください)
*「my_shared_secret」の部分は実際の IPsec 事前共有鍵[Pre-shared Secret](任意
の文字列)で置き換えてください。
7.
ID 設定
set vpn ipsec site-to-site peer 198.51.100.1 authentication id @cloud
set vpn ipsec site-to-site peer 198.51.100.1 authentication remote-id @branch
クラウド側 VyOS とブランチ側デバイスの ID を設定します。
*ID の頭に@ (半角)を付加します。
* could と branch の部分は実際の値に置き換えてください。
- 32 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
8.
VyOS での IPsec サイト間 VPN 接続ガイド
自分自身(クラウド側 VyOS)の eth0 の IP アドレスを設定
set vpn ipsec site-to-site peer 198.51.100.1 local-address 10.1.1.1
* 10.1.1.1 の部分は実際のクラウド側 VyOS の eth0 の IP アドレスの値に置き換え
てください。
9.
IPsec トンネルを通す宛先ネットワークと送信元ネットワークの対を設定
set vpn ipsec site-to-site peer 198.51.100.1 tunnel 1 local prefix 10.1.0.0/22
set vpn ipsec site-to-site peer 198.51.100.1 tunnel 1 remote prefix 10.5.10.0/24
*IP アドレスは実際の設定に置き換えてください。
- 198.51.100.1 は実際のブランチ側デバイスのグローバル IP アドレスに置き換え。
- 10.1.0.0/22 は実際のクラウド側のネットワークアドレスに置き換え。
- 10.5.10.0/24 は実際のブランチ側のネットワークに置き換え。
10. ファイアウォールのルール設定
set firewall name FW_RULE rule 100 action accept
set firewall name FW_RULE rule 100 source address 10.1.0.0/22
set firewall name FW_RULE rule 110 action accept
set firewall name FW_RULE rule 110 source address 10.5.10.0/24
*NW アドレスは実際の設定に置き換えてください。
*rule 番号(上記 100 と 110)は任意で設定します。
上記例では、「FW_RULE」という名前(任意)のルールにて、クラウド側のネットワークアド
レスとブランチ側のネットワークアドレスからのパケットを許可する設定を追加しています。
VyOS では、Firewall のルールで許可されていないパケットは拒否されます。
*もし eth0 に対して送受信時のフィルタを定義している場合(set interfaces ethernet
eth0 firewall in の設定がされている場合)は、クラウド側のネットワークとブランチ側
のネットワークの双方で通信ができるためのルールが設定されている必要があります。
*また、VyOS 自身に対してフィルタを定義している場合(set interfaces ethernet eth0 firewall
local の設定がされている場合)は peer 同士の IP アドレスを許可する設定が必要となります。
- 33 © IDC Frontier Inc. All Rights Reserved
VyOS での IPsec サイト間 VPN 接続ガイド
セルフクラウド
ブランチ側 VyOS の設定
6.2.
以下に設定手順をご案内します。設定内容は例となります。適宜変更して設定してください。
WAN 側の Ethernet インターフェース
1.
eth0
基本的にはクラウド側 VyOS と同じ設定を行います。
(アドレスやネットワーク、 ID などの情報が入れ替わるだけです。
)
set vpn ipsec esp-group ESP-G lifetime 1800
set vpn ipsec esp-group ESP-G proposal 1 encryption 3des
set vpn ipsec esp-group ESP-G proposal 1 hash md5
set vpn ipsec ike-group IKE-G lifetime 3600
set vpn ipsec ike-group IKE-G proposal 1 encryption 3des
set vpn ipsec ike-group IKE-G proposal 1 hash md5
set vpn ipsec ipsec-interfaces interface eth0
set vpn ipsec nat-traversal enable
set vpn ipsec site-to-site peer 203.0.113.1 authentication id @branch
set vpn ipsec site-to-site peer 203.0.113.1 authentication mode pre-shared-secret
set
vpn
ipsec
site-to-site
peer
203.0.113.1
authentication
pre-shared-secret
my_shared_secret (*1 行で入力してください)
set vpn ipsec site-to-site peer 203.0.113.1 authentication remote-id @cloud
set vpn ipsec site-to-site peer 203.0.113.1 default-esp-group ESP-G
set vpn ipsec site-to-site peer 203.0.113.1 ike-group IKE-G
set vpn ipsec site-to-site peer 203.0.113.1 local-address 10.1.1.1
set vpn ipsec site-to-site peer 203.0.113.1 tunnel 1 local prefix 10.5.10.0/24
set vpn ipsec site-to-site peer 203.0.113.1 tunnel 1 remote prefix 10.1.0.0/22
ただし、 WAN 側で NAT を使用している場合は注意点があります。
VyOS では IPsec を通すか通さないかの判断をする前の段階で、NAT のルールが適用
されてしまうため、 NAT ルールから、以下を除外する必要があります。
■「宛先アドレスがクラウド側のネットワークアドレス」を除外
set nat source rule 1 destination address 10.1.0.0/22
仮に rule 1 として Source NAT が設定されている場合、上記のコマンドで「宛先アド
レスがクラウド側のネットワークアドレス」のパケットを NAT ルールから除外すること
ができます。
- 34 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
お問合わせ
7.
サービスに関するお問合わせは、ポータル内のお問合わせチケットシステムを利用したオ
ンラインサポートをご利用ください。また、プレミアムサポート(有償オプション)をお申
し込みいただければ、お電話でのお問い合わせも可能となります。
※ただし、VyOS の接続設定は、当社サポート範囲外となっておりますので、あらかじめ
ご了承ください。設定サポートをご希望の場合、当社協力会社のご紹介が可能です。ご相談
ください。
項目
内容
オンラインサポート (標準)
[チケットシステム]
サービス問合せ
平日 09:00~17:00
故障問合せ
24 時間 365 日
プレミアムサポート (有償)
(※電話)
サービス・故障問合せ
平日 09:00~17:00
※プレミアムサポートは電話サポートが可能となるサービスです。
サポートコンテンツ
7.1.
サービス稼働状況の確認が可能です。
ご説明
操作方法
①サービス全体の故
障やメンテナンス
が無いか「サービス
稼動状況」でご確認
ください。
計画メンテナンスが
ある場合は、
「スケ
ジュールメンテナン
ス」に表示されます
- 35 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
オンラインサポート
7.2.
FAQ などでも問題が解決しない場合は、問合せチケットにてお問合せください。
ご説明
操作方法
① サポート」-「問い合わせ
チケット」にアクセスしま
す。
② 「新規チケット」ボタンを
クリックします。
③ タイトルと説明にお問い
合わせ内容を入力し「登録」
をクリック
※不具合のお問合わせの場合、OS や仮想マシン名(i から
始まる番号)、テンプレート名、ブラウザなどの詳細情
報を記載いただけますと、調査時間の短縮につながりま
す。ご協力をお願いいたします。
- 36 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
③
VyOS での IPsec サイト間 VPN 接続ガイド
チケットを登録すると、す
ぐにご登録メールアドレス
宛てに、チケットが登録さ
れたことをメールでお知ら
せします。
その後、チケットが更新さ
れる度に、メールでお知ら
せします。更新内容は「コ
メント」欄に記載されます
ので、ポータルにログイン
しなくても調査結果をメー
ルで確認することが可能で
す。
- 37 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
プレミアムサポート
7.3.
プレミアムサポート(有償)を申し込むと、お電話での問合せが可能です。
ご説明
操作方法
① ダッシュボードのプレミ
アムサポートサインアッ
プからサインアップしま
す。
① 申し込みが完了すると、ダ
ッシュボードにプレミアム
サポートの情報が表示され
るようになります。お電話
での問い合わせの際は、サ
ポート ID とサポート PIN
を ス タ ッ フ に お伝 え 下さ
い。
※サポート ID とサポート
PIN が確認できない場合お
電話でのお問い合わせは受
けられません。
- 38 © IDC Frontier Inc. All Rights Reserved
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
改版履歴
改訂日
改訂章
改訂内容
2014 年 7 月 23 日
全章
新規作成
© IDC Frontier, Inc. All Rights Reserved.
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
セルフクラウド
VyOS での IPsec サイト間 VPN 接続ガイド
サービスマニュアル
Ver.1.00
発行日:2014 年 7 月 23 日
株式会社 IDC フロンティア
〒160-0004 東京都新宿区四谷 4-29
http://www.idcf.jp/
CS-PUB-M0127-ET
© IDC Frontier, Inc. All Rights Reserved.