Números Aleatorios

ICM00794. Fundamentos de Computación
www.icm.espol.edu.ec/materias/icm00794
Aleatorios y Tipos de Variables
Aleatorios
Para simular un número de azar, por ejemplo el obtenido al lanzar un dado, se recurre al concepto de
números aleatorios.
Un número aleatorio se define como un número cualquiera real en el rango [0,1)
Para utilizar el número aleatorio se debe convertir al rango apropiado del número a simular, por ejemplo, para
simular un dado se escribiría en el algoritmo:
dado ← entero(aleatorio*6)+1
Que básicamente describe que:
- aleatorio es un número real [0,1),
- como el dado tiene 6 caras se multiplica por 6, obteniendo un real de [0,6). No se incluye el 6.
- Se extrae solo la parte entera para obtener un número entero [0,5]
- Para que el resultado sea [1,6], se le suma 1
Rsm06_Aleatorios
M.A. Ing. Edison Del Rosario
[email protected]
1
ICM00794. Fundamentos de Computación
www.icm.espol.edu.ec/materias/icm00794
Ejercicio 1
Realice un algoritmo para simular el precio del barril de petróleo durante un mes de 30 días, suponiendo que
son valores enteros que fluctúan en forma aleatoria entre $ 130 y $ 150 y se obtenga las siguientes
respuestas:
a) El promedio del precio del petróleo.
b) ¿Cuál fue el día en el que estuvo más barato el barril de petróleo?
Referencia: ESPOL-FCNM. ICM00794-Fundamentos de Computación. 1ra Evaluación I Término 2008 - 2009.
Julio 08, 2008. Tema 3
Desarrollo: Para iniciar el algoritmo, se puede considerar como variable de entrada los días del mes, o
asignarles directamente 30 días.
La primera aproximación al problema para responder el literal a) consiste en generar números aleatorios en
el rango [130, 150] y acumular sus valores para el promedio. Será necesario disponer de un contador para
controlar el número de veces que se generan los precios de forma aleatoria en el lazo de repetición.
Una de las formas de resolver el problema es con un lazo repita hasta, cuyo diagrama de flujo se muestra a
continuación:
Rsm06_Aleatorios
M.A. Ing. Edison Del Rosario
[email protected]
2
ICM00794. Fundamentos de Computación
www.icm.espol.edu.ec/materias/icm00794
Proceso promedioprecio
Leer diasmes
total←0
dia←0
rango←(150-130)+1
Repetir
precio←TRUNC(AZAR(rango))+130
total←total+precio
dia←dia+1
Hasta Que dia>=diasmes
promedio←total/diasmes
Mostrar promedio
FinProceso
Para la pregunta b) es necesario analizar la manera de encontrar el día con el precio más barato. En este
caso se utilizará el algoritmo para búsqueda del menor, que consiste en iniciar con el supuesto para el valor
menor de precio y día, probando contra el precio de cada día y de ser necesario se cambian los valores
menores. Es un similar al caso de usar una hipótesis y realizar luego las pruebas.
Como supuesto, se escogerá el valor máximo de precio con el objetivo que el primer precio que aparece
sustituye los valores.
Rsm06_Aleatorios
M.A. Ing. Edison Del Rosario
[email protected]
3
ICM00794. Fundamentos de Computación
www.icm.espol.edu.ec/materias/icm00794
Proceso promedioprecioab
Leer diasmes
total←0
dia←0
rango←(150-130)+1
diamenor←0
preciomenor←150
Repetir
precio←TRUNC(AZAR(rango))+130
Rsm06_Aleatorios
M.A. Ing. Edison Del Rosario
[email protected]
4
ICM00794. Fundamentos de Computación
www.icm.espol.edu.ec/materias/icm00794
total←total+precio
Si precio<preciomenor Entonces
diamenor←dia
preciomenor←precio
FinSi
dia←dia+1
Hasta Que dia>=diasmes
promedio←total/diasmes
Mostrar promedio
Mostrar diamenor
FinProceso
Otra forma de realizar el algoritmo consiste en cambiar la perspectiva del lazo repita- hasta por un mientras
repita. Para el cambio será necesario solo negar la expresión usada en el lazo repita-hasta en días<diasmes.
Rsm06_Aleatorios
M.A. Ing. Edison Del Rosario
[email protected]
5
ICM00794. Fundamentos de Computación
www.icm.espol.edu.ec/materias/icm00794
Proceso promedioprecioab
Leer diasmes
total←0
dia←0
rango←(150-130)+1
diamenor←0
preciomenor←150
Mientras dia<diasmes Hacer
Rsm06_Aleatorios
M.A. Ing. Edison Del Rosario
[email protected]
6
ICM00794. Fundamentos de Computación
www.icm.espol.edu.ec/materias/icm00794
precio←TRUNC(AZAR(rango))+130
total←total+precio
Si precio<preciomenor Entonces
diamenor←dia
preciomenor←precio
FinSi
dia←dia+1
Fin Mientras
promedio←total/diasmes
Mostrar promedio
Mostrar diamenor
FinProceso
Ejercicio 2
“Tiro al blanco” es un juego que consiste en lanzar dardos a un objetivo circular. El premio que gana el
jugador, depende de la ubicación en la cual cae el dardo y su valor se reparte en dólares ($30, $40 o $50), tal
como se muestra en la figura:
Existen 3 círculos concéntricos (que tienen el mismo centro) y las longitudes de los radios del primero,
segundo y tercer círculos son 10cm, 40cm y 80cm, respectivamente. Suponga que los 3 círculos están
inscritos en un cuadrado de longitud de lado 160cm.
Escriba un algoritmo que permita simular n lanzamientos aleatorios de dardos, asignando de forma
aleatoria pares ordenados (x, y) en el cuadrado descrito. En cada lanzamiento se debe verificar si el dardo se
ubica al interior de alguno de los círculos descritos y asignar el respectivo premio. Al final, muestre el premio
total en dólares que obtuvo el jugador.
Referencia: ESPOL-FCNM. ICM00794-Fundamentos de Computación. 1ra Evaluación I Término 2007 - 2008. Julio 03, 2007
Desarrollo: Como bloque de ingreso, se usará la variable n como el número de dardos cuyo lanzamiento será
simulado. Las coordenadas de los puntos donde cae cada dardo serán referenciadas al centro de los círculos,
por lo que los rangos para el eje x y el eje y serán [-80, 80].
Si las coordenadas serán aleatorias el rango del aleatorio será 80-(-80)=160, con valor inicial de -80 como se
describe en la siguiente expresión:
Coordenada px ← entero(aleatorio*160)-80
Rsm06_Aleatorios
M.A. Ing. Edison Del Rosario
[email protected]
7
ICM00794. Fundamentos de Computación
www.icm.espol.edu.ec/materias/icm00794
Al calcular la distancia de la coordenada del dardo al origen, usando la fórmula de distancia entre dos
puntos, se determinará la franja sobre la que cayó el dardo.
 = √ 2 +  2
En seudo-código el algoritmo se expresa como:
Proceso tabladardosa
Leer n
premio←0
dardo←0
Repetir
px←(AZAR(160)-80)
Rsm06_Aleatorios
M.A. Ing. Edison Del Rosario
[email protected]
8
ICM00794. Fundamentos de Computación
www.icm.espol.edu.ec/materias/icm00794
py←(AZAR(160)-80)
d←RAIZ(px^2+py^2)
Si d<10 Entonces
premio←premio+50
FinSi
Si d>=10& d<40 Entonces
premio←premio+40
FinSi
Si d>=40& d<80 Entonces
premio←premio+30
FinSi
dardo ← dardo+1
Hasta Que dardo>=n
Mostrar premio
FinProceso
Como ejercicio se propone realizar el diagrama de flujo usando el lazo Mientras-Repita:
Proceso tabladardosb
Leer n
premio←0
dardo←0
Mientras dardo<=n Hacer
px←(AZAR(160)-80)
py←(AZAR(160)-80)
d←RAIZ(px^2+py^2)
Si d<10 Entonces
premio←premio+50
FinSi
Si d>=10& d<40 Entonces
premio←premio+40
FinSi
Si d>=40& d<80 Entonces
premio←premio+30
FinSi
dardo ← dardo+1
FinMientras
Mostrar premio
FinProceso
Ejercicio 3
Encuentre un valor aproximado de la constante π con el siguiente procedimiento:
Considere un círculo de radio unitario, centrado en el origen e inscrito en un cuadrado:
Rsm06_Aleatorios
M.A. Ing. Edison Del Rosario
[email protected]
9
ICM00794. Fundamentos de Computación
www.icm.espol.edu.ec/materias/icm00794
Para n puntos (x, y) con coordenadas generadas de forma aleatoria reales entre 0 y 1, determine cuántos
puntos caen dentro del cuadrante de círculo.
Si llamamos a este contador k, se puede establecer la siguiente relación aproximada suponiendo n grande:
Donde se puede obtener el valor aproximado de π
Referencia: ESPOL-FCNM. ICM00794-Fundamentos de Computación. Parcial II Término 2004 - 2005. Diciembre, 2004. Tema 3
Ejercicio 4
En un plano cartesiano se encuentran una hormiga y un grano de arroz. En cada instante de tiempo, la
hormiga de manera aleatoria intuye la dirección donde ir (arriba, abajo, derecha, izquierda), y cuantas
unidades desplazarse (entre 1 a 3) en la anterior dirección.
Implemente un algoritmo que simule 100 instantes de tiempo con desplazamientos de la hormiga que
inicialmente se encuentra en las coordenadas (-2,2) y un grano de arroz en las coordenadas (10,8)
Al final indique las respuestas a las siguientes preguntas:
1. ¿La hormiga llegó al grano de arroz?
2. Si la respuesta a la pregunta anterior es “Si”, entonces mostrar: cuántos pasos fueron necesarios.
3. ¿La distancia más lejana en la que estuvo la hormiga del grano de arroz?
Referencia: ESPOL-FCNM. ICM00794-Fundamentos de Computación. 1ra Evaluación II Término 2007 - 2008. Diciembre 04, 2007.
Tema 1.
Rsm06_Aleatorios
M.A. Ing. Edison Del Rosario
[email protected]
10
ICM00794. Fundamentos de Computación
www.icm.espol.edu.ec/materias/icm00794
Ejercicio 5
Para una nueva versión del juego “Escaleras y Serpientes” se desea disponer del algoritmo para simulación
en computador.
El juego de dos jugadores consiste en llegar a la meta en primer lugar en un tablero de 64 casillas cuyas
especificaciones son las siguientes:
1. Cada jugador realiza su recorrido alternadamente de acuerdo a los resultados de los lanzamientos de un
dado (6 caras)
2. Al avanzar, el jugador puede “caer” en una “casilla de castigo”, por lo que retrocederá 3 pasos de la
posición en la que se encuentra. Si cae en “casilla de premio”, el usuario avanzará 3 pasos de la posición en
la que se encuentra.
3. Luego de un lanzamiento y determinación de la posición final, el jugador le pasa el turno al otro jugador.
4. Se repite el juego desde el paso 2 hasta que uno de los jugadores pase la meta.
Al final se deberá mostrar:
- Número de veces jugadas por cada jugador, y
- El jugador que ganó.
Nota: casillas de premio para éste tema son: 4, 9, 29, 34, 46 y de castigo: 8, 19, 38, 50, 60
http://tiempocompletozacatecas.com/?product=juego-de-serpientes-y-escaleras-en-diseno-sobre-lona-impresa-de-5030-cms-y-undado-de-2-cms
Referencia: ESPOL-FCNM. ICM00794-Fundamentos de Computación. Parcial II Término 2005 - 2006. Diciembre 06, 2005. Tema 4
Ejercicio 6
En el Fútbol el lanzamiento de penales intervienen el jugador que patea y el arquero que tapa el penal.
Este juego consiste en 5 lanzamientos por parte de los jugadores que patean el balón, los cuales pueden
decidir lanzar en cualquiera de las seis secciones del arco (1: arriba a la derecha, 2: arriba al centro, 3: arriba
a la izquierda, 4 abajo a la izquierda, 5: abajo al centro, 6: abajo a la derecha).
En cada lanzamiento, el arquero decide donde ubicarse para atajar el tiro y no tiene oportunidad de cubrir
otra sección, si éste coincide con la ubicación donde disparó el jugador, entonces el lanzamiento fue atajado
o fallado, caso contrario se marcó un GOL.
Escriba un algoritmo que simule un juego de 5 lanzamientos de penales, en donde la sección del arco donde
cada jugador lanza es decidido por el usuario y la sección cubierta por el arquero es simulado por el
computador (aleatoria).
Al final presente la siguiente información:
• Cantidad de goles conseguidos.
• Cantidad de penales fallados.
• La cantidad de goles realizados en la parte derecha, central e izquierda del arco.
Rsm06_Aleatorios
M.A. Ing. Edison Del Rosario
[email protected]
11
ICM00794. Fundamentos de Computación
www.icm.espol.edu.ec/materias/icm00794
• La ubicación del arco (derecha, centro o izquierda) por donde ingresaron más goles. Suponga que existe
una sola.
• La ubicación del arco (derecha, centro o izquierda) por donde no ingresaron goles. Suponga que existe una
sola.
Referencia: ESPOL-FCNM. ICM00794-Fundamentos de Computación. Parcial I Término 2005 - 2006. Julio 05, 2005. Tema 4
Rsm06_Aleatorios
M.A. Ing. Edison Del Rosario
[email protected]
12